Обновление PHP 5.5 до PHP 5.6 в Ubuntu 14.04 (Upgrade PHP Version)

Всем привет, как Вы знаете уже вышел релиз новой версии интерпритатора PHP 5.6 и многие владельцы операционной системы Ubuntu 14.04 задали себе вопрос, а как, собственно, обновить мою версию PHP 5.5 до 5.6 не меня и не переустанавливая при этом систему или, проводя каких то сложных компиляций и сборок новой версии.
Ответ на самом деле очень прост, все можно сделать легко благодаря PPA. Итак приступим.

  1. Для начала давайте добавим некоторые компоненты Phyton  в систему. Открываем терминал и копируем туда следующее:
sudo apt-get update && sudo apt-get install python-software-properties
  1.  После этого мы можем добавить PPA PHP 5.6  в нашу систему используя команду
sudo add-apt-repository ppa:ondrej/php5-5.6
  1. После добавления PPA  конечно же обязательно по стандарту
sudo apt-get update && sudo apt-get upgrade
  1. Теперь устанавливаем PHP 5.6 командой
sudo apt-get install php5

В итоге получаем
Screenshot_1

Вот собственно и все. Спасибо за внимание. Если что-то не получается, обязательно пишите в комментариях, будем разбираться

4 комментария к “Обновление PHP 5.5 до PHP 5.6 в Ubuntu 14.04 (Upgrade PHP Version)”

  1. Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    php5 : Зависит: libapache2-mod-php5 (>= 5.6.14+dfsg-1+deb.sury.org~trusty+1~) но он не будет установлен или
    libapache2-mod-php5filter (>= 5.6.14+dfsg-1+deb.sury.org~trusty+1~) но он не будет установлен или
    php5-cgi (>= 5.6.14+dfsg-1+deb.sury.org~trusty+1~) но он не будет установлен или
    php5-fpm (>= 5.6.14+dfsg-1+deb.sury.org~trusty+1~) но он не будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

      1. Андрей Боргояков

        вот и хорошо что получилось

  2. Андрей

    Спасибо. Инструкция помогла. А то обновил phpunit до 5.0.3 а он оказывается уже не поддерживает PHP 5.5.9.

Оставьте комментарий

%d такие блоггеры, как: